Index Page and Help
This data is part of a licensed program from BERKELEY SOFTWARE
DESIGN, INC. Portions are copyrighted by BSDI, The Regents of
the University of California, Massachusetts Institute of
Technology, Free Software Foundation, and others.
RSHD(8) \375#009;\375#009;FreeBSD System Manager's Manual \375#009; RSHD(8) NAME rshd -- remote shell server SYNOPSIS rshd [-aDLln] DESCRIPTION The rshd utility is the server for the rcmd(3) routine and, consequently, for the rsh(1) utility. The server provides remote execution facilities with authentication based on privileged port numbers from trusted hosts. The rshd utility listens for service requests at the port indicated in the ``cmd'' service specification; see services(5). When a service request is received the following protocol is initiated: 1. The server checks the client's source port. If the port is not in \375#009; the range 512-1023, the server aborts the connection. 2. The server reads characters from the socket up to a NUL (`\0') byte. \375#009; The resultant string is interpreted as an ASCII number, base 10. 3. If the number received in step 2 is non-zero, it is interpreted as \375#009; the port number of a secondary stream to be used for the stderr. A \375#009; second connection is then created to the specified port on the \375#009; client's machine. The source port of this second connection is also \375#009; in the range 512-1023. 4. The server checks the client's source address and requests the cor- \375#009; responding host name (see gethostbyaddr(3), hosts(5) and named(8)). \375#009; If the hostname cannot be determined or the hostname and address do \375#009; not match after verification, the dot-notation representation of the \375#009; host address is used. 5. A null terminated user name of at most 16 characters is retrieved on \375#009; the initial socket. This user name is interpreted as the user iden- \375#009; tity on the client's machine. 6. A null terminated user name of at most 16 characters is retrieved on \375#009; the initial socket. This user name is interpreted as a user iden- \375#009; tity to use on the server's machine. 7. A null terminated command to be passed to a shell is retrieved on \375#009; the initial socket. The length of the command is limited by the \375#009; upper bound on the size of the system's argument list. 8. The rshd utility then validates the user using ruserok(3), which \375#009; uses the file /etc/hosts.equiv and the .rhosts file found in the \375#009; user's home directory. The -l option prevents ruserok(3) from doing \375#009; any validation based on the user's .rhosts file, unless the user is \375#009; the superuser. 9. A NUL byte is returned on the initial socket and the command line is \375#009; passed to the normal login shell of the user. The shell inherits \375#009; the network connections established by rshd. The options are as follows: -a This flag is ignored, and is present for compatability purposes. -D Sets the TCP_NODELAY socket option, which improves the perfor- \375#009; mance of small back-to-back writes at the expense of additional \375#009; network traffic. -L Causes all successful accesses to be logged to syslogd(8) as \375#009; auth.info messages. -l Do not use the user's .rhosts file for authentication, unless the \375#009; user is the superuser. -n Turn off transport level keepalive messages. This will prevent \375#009; sessions from timing out if the client crashes or becomes \375#009; unreachable. FILES /etc/hosts /etc/hosts.equiv /etc/login.conf $HOME/.rhosts /etc/pam.conf rshd uses /etc/pam.conf entries with service name \375#009;\375#009; ``rsh''. Authentication modules requiring passwords \375#009;\375#009; (such as pamunix) are not supported. DIAGNOSTICS Except for the last one listed below, all diagnostic messages are returned on the initial socket, after which any network connections are closed. An error is indicated by a leading byte with a value of 1 (0 is returned in step 10 above upon successful completion of all the steps prior to the execution of the login shell). Locuser too long. \375#009; The name of the user on the client's machine is longer than 16 \375#009; characters. Ruser too long. \375#009; The name of the user on the remote machine is longer than 16 \375#009; characters. Command too long. \375#009; The command line passed exceeds the size of the argument list (as \375#009; configured into the system). Login incorrect. \375#009; No password file entry for the user name existed or the authenti- \375#009; cation procedure described above failed. Remote directory. \375#009; The chdir(2) function to the home directory failed. Logins not available right now. \375#009; The rsh(1) utility was attempted outside the allowed hours \375#009; defined in /etc/login.conf for the local user's login class. Can't make pipe. \375#009; The pipe needed for the stderr, was not created. Can't fork; try again. \375#009; A fork(2) by the server failed. <shellname>: ... \375#009; The user's login shell could not be started. This message is \375#009; returned on the connection associated with the stderr, and is not \375#009; preceded by a flag byte. SEE ALSO rlogin(1), rsh(1), gethostbyaddr(3), rcmd(3), ruserok(3), auth.conf(5), hosts(5), hosts.equiv(5), login.conf(5), services(5), named(8), rlogind(8), syslogd(8) HISTORY IPv6 support was added by WIDE/KAME project. BUGS The authentication procedure used here assumes the integrity of each client machine and the connecting medium.\375#009;This is insecure, but is use- ful in an ``open'' environment. A facility to allow all data exchanges to be encrypted should be present. Post-PAM, FreeBSD also needs the following patch applied besides properly configuring .rhosts: \375#009; --- etc/pam.d/rsh.orig Wed Dec 17 14:36:20 2003 \375#009; +++ etc/pam.d/rsh\375#009; Wed Dec 17 14:30:43 2003 \375#009; @@ -9 +9 @@ \375#009; -auth required\375#009; pam_rhosts.so no_warn \375#009; +auth required\375#009; pam_rhosts.so no_warn allow_root A more extensible protocol (such as Telnet) should be used. FreeBSD 6.2\375#009;\375#009;\375#009; June 4, 1993\375#009;\375#009;\375#009; FreeBSD 6.2