Index Page and Help
This data is part of a licensed program from BERKELEY SOFTWARE
DESIGN, INC. Portions are copyrighted by BSDI, The Regents of
the University of California, Massachusetts Institute of
Technology, Free Software Foundation, and others.
SSHD(8) \375#009;\375#009;FreeBSD System Manager's Manual \375#009; SSHD(8) NAME sshd -- OpenSSH SSH daemon SYNOPSIS sshd [-46DdeiqTt] [-b bits] [-C connection_spec] [-f config_file] \375#009; [-g login_grace_time] [-h host_key_file] [-k key_gen_time] \375#009; [-o option] [-p port] [-u len] DESCRIPTION sshd (OpenSSH Daemon) is the daemon program for ssh(1). Together these programs replace rlogin(1) and rsh(1), and provide secure encrypted com- munications between two untrusted hosts over an insecure network. sshd listens for connections from clients. It is normally started at boot from /usr/local/etc/rc.d/openssh. It forks a new daemon for each incoming connection. The forked daemons handle key exchange, encryption, authentication, command execution, and data exchange. sshd can be configured using command-line options or a configuration file (by default sshd_config(5)); command-line options override values speci- fied in the configuration file. sshd rereads its configuration file when it receives a hangup signal, SIGHUP, by executing itself with the name and options it was started with, e.g. /usr/sbin/sshd. The options are as follows: -4 Forces sshd to use IPv4 addresses only. -6 Forces sshd to use IPv6 addresses only. -b bits \375#009; Specifies the number of bits in the ephemeral protocol version 1 \375#009; server key (default 1024). -C connection_spec \375#009; Specify the connection parameters to use for the -T extended test \375#009; mode. If provided, any Match directives in the configuration \375#009; file that would apply to the specified user, host, and address \375#009; will be set before the configuration is written to standard out- \375#009; put. The connection parameters are supplied as keyword=value \375#009; pairs. The keywords are ``user'', ``host'', and ``addr''. All \375#009; are required and may be supplied in any order, either with multi- \375#009; ple -C options or as a comma-separated list. -D When this option is specified, sshd will not detach and does not \375#009; become a daemon. This allows easy monitoring of sshd. -d Debug mode. The server sends verbose debug output to the system \375#009; log, and does not put itself in the background. The server also \375#009; will not fork and will only process one connection. This option \375#009; is only intended for debugging for the server. Multiple -d \375#009; options increase the debugging level. Maximum is 3. -e When this option is specified, sshd will send the output to the \375#009; standard error instead of the system log. -f config_file \375#009; Specifies the name of the configuration file. The default is \375#009; /etc/ssh/sshd_config. sshd refuses to start if there is no con- \375#009; figuration file. -g login_grace_time \375#009; Gives the grace time for clients to authenticate themselves \375#009; (default 120 seconds). If the client fails to authenticate the \375#009; user within this many seconds, the server disconnects and exits. \375#009; A value of zero indicates no limit. -h host_key_file \375#009; Specifies a file from which a host key is read. This option must \375#009; be given if sshd is not run as root (as the normal host key files \375#009; are normally not readable by anyone but root). The default is \375#009; /etc/ssh/ssh_host_key for protocol version 1, and \375#009; /etc/ssh/ssh_host_rsa_key and /etc/ssh/ssh_host_dsa_key for pro- \375#009; tocol version 2. It is possible to have multiple host key files \375#009; for the different protocol versions and host key algorithms. -i Specifies that sshd is being run from inetd(8). sshd is normally \375#009; not run from inetd because it needs to generate the server key \375#009; before it can respond to the client, and this may take tens of \375#009; seconds. Clients would have to wait too long if the key was \375#009; regenerated every time. However, with small key sizes (e.g. 512) \375#009; using sshd from inetd may be feasible. -k key_gen_time \375#009; Specifies how often the ephemeral protocol version 1 server key \375#009; is regenerated (default 3600 seconds, or one hour). The motiva- \375#009; tion for regenerating the key fairly often is that the key is not \375#009; stored anywhere, and after about an hour it becomes impossible to \375#009; recover the key for decrypting intercepted communications even if \375#009; the machine is cracked into or physically seized.\375#009;A value of \375#009; zero indicates that the key will never be regenerated. -o option \375#009; Can be used to give options in the format used in the configura- \375#009; tion file. This is useful for specifying options for which there \375#009; is no separate command-line flag.\375#009;For full details of the \375#009; options, and their values, see sshd_config(5). -p port \375#009; Specifies the port on which the server listens for connections \375#009; (default 22). Multiple port options are permitted. Ports speci- \375#009; fied in the configuration file with the Port option are ignored \375#009; when a command-line port is specified. Ports specified using the \375#009; ListenAddress option override command-line ports. -q Quiet mode. Nothing is sent to the system log. Normally the \375#009; beginning, authentication, and termination of each connection is \375#009; logged. -T Extended test mode. Check the validity of the configuration \375#009; file, output the effective configuration to stdout and then exit. \375#009; Optionally, Match rules may be applied by specifying the connec- \375#009; tion parameters using one or more -C options. -t Test mode. Only check the validity of the configuration file and \375#009; sanity of the keys. This is useful for updating sshd reliably as \375#009; configuration options may change. -u len This option is used to specify the size of the field in the utmp \375#009; structure that holds the remote host name. If the resolved host \375#009; name is longer than len, the dotted decimal value will be used \375#009; instead. This allows hosts with very long host names that over- \375#009; flow this field to still be uniquely identified. Specifying -u0 \375#009; indicates that only dotted decimal addresses should be put into \375#009; the utmp file. -u0 may also be used to prevent sshd from making \375#009; DNS requests unless the authentication mechanism or configuration \375#009; requires it. Authentication mechanisms that may require DNS \375#009; include RhostsRSAAuthentication, HostbasedAuthentication, and \375#009; using a from="pattern-list" option in a key file.\375#009;Configuration \375#009; options that require DNS include using a USER@HOST pattern in \375#009; AllowUsers or DenyUsers. AUTHENTICATION The OpenSSH SSH daemon supports SSH protocols 1 and 2. Both protocols are supported by default, though this can be changed via the Protocol option in sshd_config(5).\375#009;Protocol 2 supports both RSA and DSA keys; protocol 1 only supports RSA keys. For both protocols, each host has a host-specific key, normally 2048 bits, used to identify the host. Forward security for protocol 1 is provided through an additional server key, normally 768 bits, generated when the server starts.\375#009;This key is normally regenerated every hour if it has been used, and is never stored on disk. Whenever a client connects, the daemon responds with its public host and server keys. The client compares the RSA host key against its own database to verify that it has not changed. The client then gener- ates a 256-bit random number. It encrypts this random number using both the host key and the server key, and sends the encrypted number to the server. Both sides then use this random number as a session key which is used to encrypt all further communications in the session. The rest of the session is encrypted using a conventional cipher, currently Blowfish or 3DES, with 3DES being used by default.\375#009;The client selects the encryp- tion algorithm to use from those offered by the server. For protocol 2, forward security is provided through a Diffie-Hellman key agreement. This key agreement results in a shared session key. The rest of the session is encrypted using a symmetric cipher, currently 128-bit AES, Blowfish, 3DES, CAST128, Arcfour, 192-bit AES, or 256-bit AES. The client selects the encryption algorithm to use from those offered by the server. Additionally, session integrity is provided through a crypto- graphic message authentication code (hmac-md5, hmac-sha1, umac-64 or hmac-ripemd160). Finally, the server and the client enter an authentication dialog. The client tries to authenticate itself using host-based authentication, pub- lic key authentication, challenge-response authentication, or password authentication. Regardless of the authentication type, the account is checked to ensure that it is accessible. An account is not accessible if it is locked, listed in DenyUsers or its group is listed in DenyGroups . The defini- tion of a locked account is system dependant. Some platforms have their own account database (eg AIX) and some modify the passwd field ( `*LK*' on Solaris and UnixWare, `*' on HP-UX, containing `Nologin' on Tru64, a leading `*LOCKED*' on FreeBSD and a leading `!' on most Linuxes).\375#009;If there is a requirement to disable password authentication for the account while allowing still public-key, then the passwd field should be set to something other than these values (eg `NP' or `*NP*' ). If the client successfully authenticates itself, a dialog for preparing the session is entered. At this time the client may request things like allocating a pseudo-tty, forwarding X11 connections, forwarding TCP con- nections, or forwarding the authentication agent connection over the secure channel. After this, the client either requests a shell or execution of a command. The sides then enter session mode. In this mode, either side may send data at any time, and such data is forwarded to/from the shell or command on the server side, and the user terminal in the client side. When the user program terminates and all forwarded X11 and other connec- tions have been closed, the server sends command exit status to the client, and both sides exit. LOGIN PROCESS When a user successfully logs in, sshd does the following: \375#009; 1.\375#009;If the login is on a tty, and no command has been specified, \375#009;\375#009;prints last login time and /etc/motd (unless prevented in the \375#009;\375#009;configuration file or by ~/.hushlogin; see the FILES section). \375#009; 2.\375#009;If the login is on a tty, records login time. \375#009; 3.\375#009;Checks /etc/nologin and /var/run/nologin; if one exists, it \375#009;\375#009;prints the contents and quits (unless root). \375#009; 4.\375#009;Changes to run with normal user privileges. \375#009; 5.\375#009;Sets up basic environment. \375#009; 6.\375#009;Reads the file ~/.ssh/environment, if it exists, and users are \375#009;\375#009;allowed to change their environment. See the \375#009;\375#009;PermitUserEnvironment option in sshd_config(5). \375#009; 7.\375#009;Changes to user's home directory. \375#009; 8.\375#009;If ~/.ssh/rc exists, runs it; else if /etc/ssh/sshrc exists, \375#009;\375#009;runs it; otherwise runs xauth(1). The ``rc'' files are given \375#009;\375#009;the X11 authentication protocol and cookie in standard input. \375#009;\375#009;See SSHRC, below. \375#009; 9.\375#009;Runs user's shell or command. SSHRC If the file ~/.ssh/rc exists, sh(1) runs it after reading the environment files but before starting the user's shell or command. It must not pro- duce any output on stdout; stderr must be used instead. If X11 forward- ing is in use, it will receive the "proto cookie" pair in its standard input (and DISPLAY in its environment). The script must call xauth(1) because sshd will not run xauth automatically to add X11 cookies. The primary purpose of this file is to run any initialization routines which may be needed before the user's home directory becomes accessible; AFS is a particular example of such an environment. This file will probably contain some initialization code followed by something similar to: \375#009;if read proto cookie && [ -n "$DISPLAY" ]; then \375#009;\375#009;if [ `echo $DISPLAY | cut -c1-10` = 'localhost:' ]; then \375#009;\375#009;\375#009;# X11UseLocalhost=yes \375#009;\375#009;\375#009;echo add unix:`echo $DISPLAY | \375#009;\375#009;\375#009; cut -c11-` $proto $cookie \375#009;\375#009;else \375#009;\375#009;\375#009;# X11UseLocalhost=no \375#009;\375#009;\375#009;echo add $DISPLAY $proto $cookie \375#009;\375#009;fi | xauth -q - \375#009;fi If this file does not exist, /etc/ssh/sshrc is run, and if that does not exist either, xauth is used to add the cookie. AUTHORIZEDKEYS FILE FORMAT AuthorizedKeysFile specifies the file containing public keys for public key authentication; if none is specified, the default is ~/.ssh/authorized_keys. Each line of the file contains one key (empty lines and lines starting with a `#' are ignored as comments). Protocol 1 public keys consist of the following space-separated fields: options, bits, exponent, modulus, comment.\375#009;Protocol 2 public key consist of: options, keytype, base64-encoded key, comment. The options field is optional; its presence is determined by whether the line starts with a number or not (the options field never starts with a number). The bits, exponent, modulus, and comment fields give the RSA key for protocol ver- sion 1; the comment field is not used for anything (but may be convenient for the user to identify the key). For protocol version 2 the keytype is ``ssh-dss'' or ``ssh-rsa''. Note that lines in this file are usually several hundred bytes long (because of the size of the public key encoding) up to a limit of 8 kilo- bytes, which permits DSA keys up to 8 kilobits and RSA keys up to 16 kilobits.\375#009;You don't want to type them in; instead, copy the identity.pub, id_dsa.pub, or the id_rsa.pub file and edit it. sshd enforces a minimum RSA key modulus size for protocol 1 and protocol 2 keys of 768 bits. The options (if present) consist of comma-separated option specifica- tions. No spaces are permitted, except within double quotes. The fol- lowing option specifications are supported (note that option keywords are case-insensitive): command="command" \375#009; Specifies that the command is executed whenever this key is used \375#009; for authentication. The command supplied by the user (if any) is \375#009; ignored. The command is run on a pty if the client requests a \375#009; pty; otherwise it is run without a tty. If an 8-bit clean chan- \375#009; nel is required, one must not request a pty or should specify \375#009; no-pty. A quote may be included in the command by quoting it \375#009; with a backslash.\375#009;This option might be useful to restrict cer- \375#009; tain public keys to perform just a specific operation. An exam- \375#009; ple might be a key that permits remote backups but nothing else. \375#009; Note that the client may specify TCP and/or X11 forwarding unless \375#009; they are explicitly prohibited. The command originally supplied \375#009; by the client is available in the SSH_ORIGINAL_COMMAND environ- \375#009; ment variable. Note that this option applies to shell, command \375#009; or subsystem execution. environment="NAME=value" \375#009; Specifies that the string is to be added to the environment when \375#009; logging in using this key. Environment variables set this way \375#009; override other default environment values. Multiple options of \375#009; this type are permitted. Environment processing is disabled by \375#009; default and is controlled via the PermitUserEnvironment option. \375#009; This option is automatically disabled if UseLogin is enabled. from="pattern-list" \375#009; Specifies that in addition to public key authentication, either \375#009; the canonical name of the remote host or its IP address must be \375#009; present in the comma-separated list of patterns. See PATTERNS in \375#009; ssh_config(5) for more information on patterns. \375#009; In addition to the wildcard matching that may be applied to host- \375#009; names or addresses, a from stanza may match IP addressess using \375#009; CIDR address/masklen notation. \375#009; The purpose of this option is to optionally increase security: \375#009; public key authentication by itself does not trust the network or \375#009; name servers or anything (but the key); however, if somebody \375#009; somehow steals the key, the key permits an intruder to log in \375#009; from anywhere in the world. This additional option makes using a \375#009; stolen key more difficult (name servers and/or routers would have \375#009; to be compromised in addition to just the key). no-agent-forwarding \375#009; Forbids authentication agent forwarding when this key is used for \375#009; authentication. no-port-forwarding \375#009; Forbids TCP forwarding when this key is used for authentication. \375#009; Any port forward requests by the client will return an error. \375#009; This might be used, e.g. in connection with the command option. no-pty Prevents tty allocation (a request to allocate a pty will fail). no-user-rc \375#009; Disables execution of ~/.ssh/rc. no-X11-forwarding \375#009; Forbids X11 forwarding when this key is used for authentication. \375#009; Any X11 forward requests by the client will return an error. permitopen="host:port" \375#009; Limit local ``ssh -L'' port forwarding such that it may only con- \375#009; nect to the specified host and port. IPv6 addresses can be spec- \375#009; ified with an alternative syntax: host/port. Multiple permitopen \375#009; options may be applied separated by commas. No pattern matching \375#009; is performed on the specified hostnames, they must be literal \375#009; domains or addresses. tunnel="n" \375#009; Force a tun(4) device on the server. Without this option, the \375#009; next available device will be used if the client requests a tun- \375#009; nel. An example authorized_keys file: \375#009;# Comments allowed at start of line \375#009;ssh-rsa AAAAB3Nza...LiPk== firstname.lastname@example.org \375#009;from="*.sales.example.net,!pc.sales.example.net" ssh-rsa \375#009;AAAAB2...19Q== email@example.com \375#009;command="dump /home",no-pty,no-port-forwarding ssh-dss \375#009;AAAAC3...51R== example.net \375#009;permitopen="192.0.2.1:80",permitopen="192.0.2.2:25" ssh-dss \375#009;AAAAB5...21S== \375#009;tunnel="0",command="sh /etc/netstart tun0" ssh-rsa AAAA...== \375#009;firstname.lastname@example.org SSHKNOWNHOSTS FILE FORMAT The /etc/ssh/ssh_known_hosts and ~/.ssh/known_hosts files contain host public keys for all known hosts. The global file should be prepared by the administrator (optional), and the per-user file is maintained auto- matically: whenever the user connects from an unknown host, its key is added to the per-user file. Each line in these files contains the following fields: hostnames, bits, exponent, modulus, comment. The fields are separated by spaces. Hostnames is a comma-separated list of patterns (`*' and `?' act as wild- cards); each pattern in turn is matched against the canonical host name (when authenticating a client) or against the user-supplied name (when authenticating a server).\375#009;A pattern may also be preceded by `!' to indi- cate negation: if the host name matches a negated pattern, it is not accepted (by that line) even if it matched another pattern on the line. A hostname or address may optionally be enclosed within `[' and `]' brackets then followed by `:' and a non-standard port number. Alternately, hostnames may be stored in a hashed form which hides host names and addresses should the file's contents be disclosed. Hashed hostnames start with a `|' character. Only one hashed hostname may appear on a single line and none of the above negation or wildcard opera- tors may be applied. Bits, exponent, and modulus are taken directly from the RSA host key; they can be obtained, for example, from /etc/ssh/ssh_host_key.pub. The optional comment field continues to the end of the line, and is not used. Lines starting with `#' and empty lines are ignored as comments. When performing host authentication, authentication is accepted if any matching line has the proper key.\375#009;It is thus permissible (but not recom- mended) to have several lines or different host keys for the same names. This will inevitably happen when short forms of host names from different domains are put in the file. It is possible that the files contain con- flicting information; authentication is accepted if valid information can be found from either file. Note that the lines in these files are typically hundreds of characters long, and you definitely don't want to type in the host keys by hand. Rather, generate them by a script or by taking /etc/ssh/ssh_host_key.pub and adding the host names at the front. An example ssh_known_hosts file: \375#009;# Comments allowed at start of line \375#009;closenet,...,192.0.2.53 1024 37 159...93 closenet.example.net \375#009;cvs.example.net,192.0.2.10 ssh-rsa AAAA1234.....= \375#009;# A hashed hostname \375#009;|1|JfKTdBh7rNbXkVAQCRp4OQoPfmI=|USECr3SWf1JUPsms5AqfD5QfxkM= ssh-rsa \375#009;AAAA1234.....= FILES ~/.hushlogin \375#009; This file is used to suppress printing the last login time and \375#009; /etc/motd, if PrintLastLog and PrintMotd, respectively, are \375#009; enabled. It does not suppress printing of the banner specified \375#009; by Banner. ~/.rhosts \375#009; This file is used for host-based authentication (see ssh(1) for \375#009; more information). On some machines this file may need to be \375#009; world-readable if the user's home directory is on an NFS parti- \375#009; tion, because sshd reads it as root. Additionally, this file \375#009; must be owned by the user, and must not have write permissions \375#009; for anyone else. The recommended permission for most machines is \375#009; read/write for the user, and not accessible by others. ~/.shosts \375#009; This file is used in exactly the same way as .rhosts, but allows \375#009; host-based authentication without permitting login with \375#009; rlogin/rsh. ~/.ssh/ \375#009; This directory is the default location for all user-specific con- \375#009; figuration and authentication information. There is no general \375#009; requirement to keep the entire contents of this directory secret, \375#009; but the recommended permissions are read/write/execute for the \375#009; user, and not accessible by others. ~/.ssh/authorized_keys \375#009; Lists the public keys (RSA/DSA) that can be used for logging in \375#009; as this user. The format of this file is described above. The \375#009; content of the file is not highly sensitive, but the recommended \375#009; permissions are read/write for the user, and not accessible by \375#009; others. \375#009; If this file, the ~/.ssh directory, or the user's home directory \375#009; are writable by other users, then the file could be modified or \375#009; replaced by unauthorized users. In this case, sshd will not \375#009; allow it to be used unless the StrictModes option has been set to \375#009; ``no''. ~/.ssh/environment \375#009; This file is read into the environment at login (if it exists). \375#009; It can only contain empty lines, comment lines (that start with \375#009; `#'), and assignment lines of the form name=value. The file \375#009; should be writable only by the user; it need not be readable by \375#009; anyone else. Environment processing is disabled by default and \375#009; is controlled via the PermitUserEnvironment option. ~/.ssh/known_hosts \375#009; Contains a list of host keys for all hosts the user has logged \375#009; into that are not already in the systemwide list of known host \375#009; keys. The format of this file is described above. This file \375#009; should be writable only by root/the owner and can, but need not \375#009; be, world-readable. ~/.ssh/rc \375#009; Contains initialization routines to be run before the user's home \375#009; directory becomes accessible. This file should be writable only \375#009; by the user, and need not be readable by anyone else. /etc/hosts.allow /etc/hosts.deny \375#009; Access controls that should be enforced by tcp-wrappers are \375#009; defined here. Further details are described in hosts_access(5). /etc/hosts.equiv \375#009; This file is for host-based authentication (see ssh(1)). It \375#009; should only be writable by root. /etc/ssh/moduli \375#009; Contains Diffie-Hellman groups used for the "Diffie-Hellman Group \375#009; Exchange". The file format is described in moduli(5). /etc/motd \375#009; See motd(5). /etc/nologin \375#009; If this file exists, sshd refuses to let anyone except root log \375#009; in. The contents of the file are displayed to anyone trying to \375#009; log in, and non-root connections are refused. The file should be \375#009; world-readable. /etc/ssh/shosts.equiv \375#009; This file is used in exactly the same way as hosts.equiv, but \375#009; allows host-based authentication without permitting login with \375#009; rlogin/rsh. /etc/ssh/ssh_host_key /etc/ssh/ssh_host_dsa_key /etc/ssh/ssh_host_rsa_key \375#009; These three files contain the private parts of the host keys. \375#009; These files should only be owned by root, readable only by root, \375#009; and not accessible to others. Note that sshd does not start if \375#009; these files are group/world-accessible. /etc/ssh/ssh_host_key.pub /etc/ssh/ssh_host_dsa_key.pub /etc/ssh/ssh_host_rsa_key.pub \375#009; These three files contain the public parts of the host keys. \375#009; These files should be world-readable but writable only by root. \375#009; Their contents should match the respective private parts.\375#009;These \375#009; files are not really used for anything; they are provided for the \375#009; convenience of the user so their contents can be copied to known \375#009; hosts files. These files are created using ssh-keygen(1). /etc/ssh/ssh_known_hosts \375#009; Systemwide list of known host keys. This file should be prepared \375#009; by the system administrator to contain the public host keys of \375#009; all machines in the organization.\375#009;The format of this file is \375#009; described above. This file should be writable only by root/the \375#009; owner and should be world-readable. /etc/ssh/sshd_config \375#009; Contains configuration data for sshd. The file format and con- \375#009; figuration options are described in sshd_config(5). /etc/ssh/sshrc \375#009; Similar to ~/.ssh/rc, it can be used to specify machine-specific \375#009; login-time initializations globally. This file should be \375#009; writable only by root, and should be world-readable. /var/empty \375#009; chroot(2) directory used by sshd during privilege separation in \375#009; the pre-authentication phase. The directory should not contain \375#009; any files and must be owned by root and not group or world- \375#009; writable. /var/run/sshd.pid \375#009; Contains the process ID of the sshd listening for connections (if \375#009; there are several daemons running concurrently for different \375#009; ports, this contains the process ID of the one started last). \375#009; The content of this file is not sensitive; it can be world-read- \375#009; able. SEE ALSO scp(1), sftp(1), ssh(1), ssh-add(1), ssh-agent(1), ssh-keygen(1), ssh-keyscan(1), chroot(2), hosts_access(5), login.conf(5), moduli(5), sshd_config(5), inetd(8), sftp-server(8) AUTHORS OpenSSH is a derivative of the original and free ssh 1.2.12 release by Tatu Ylonen. Aaron Campbell, Bob Beck, Markus Friedl, Niels Provos, Theo de Raadt and Dug Song removed many bugs, re-added newer features and cre- ated OpenSSH. Markus Friedl contributed the support for SSH protocol versions 1.5 and 2.0. Niels Provos and Markus Friedl contributed support for privilege separation. CAVEATS System security is not improved unless rshd, rlogind, and rexecd are dis- abled (thus completely disabling rlogin and rsh into the machine). FreeBSD 6.2\375#009;\375#009;\375#009;March 25, 2019\375#009;\375#009;\375#009; FreeBSD 6.2